Correction to the patch_db::lookup routine description
 
Many of you may have noticed this inconsistency (because it becomes obvious from looking at the rest of the code), but just to clarify: the description of the third parameter in the "lookup" function is reversed. It currently looks like:

psi.h


Instead, such description should read:

// (input) A 2w_+1 x 2w_+1 binary matrix that indicates
// which pixels inside the target_planes[0] matrices
// *** have not been filled ***.

Everything else in the code is consistent with this updated description: including calls to this function from other sections of code that you should not modify. Note for instance the use of the variable "target_unfilled", in the call from the inpainting_algorithm.cxx file.

inpainting_algorithm.cxx


And more evidenlty, note the use of the variable name "target_unfilled", in function implementation itself.

patch_db.cxx


Special thanks to "Andrew" who brought my attention to this issue through the Discussion Forum.