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Tutorial I1l. Eclipse

Basics Eclipse Plug-in Feature

Eclipse projects:
— Eclipse platform )
« Plugin architecture » Eclipse =

* Platform, JDT, PDT - - s
* A number of integrated plugins: JUNIT, CVS, etc. acore runtime engine + a set of plug NS

— Eclipse tools project » Plug-in: the smallest extensible unit to

» CDT, VE, AspectJ, Hipikat ; i :
The official website of Eclipse: http://www.eclipse.org Cont”byte ad_dltlonal func_tlons to the system.
Eclipse forums » Extension point: boundaries between plug-ins

Articles

Eclipse plugins repository

Eclipse bugzilla

Using Eclipse in CDF:

>setenv LD_LIBRARY_PATH /local/lib/eclipse (“.cshrc”)
>eclipse




Eclipse Plug-in Structure

=0 Plug-in
@ plugin.xml ?‘ jdt.jar
|
| 7{77:)
<0 Plug-in “a e - po. ~ | @ Plug-in
= f i T
= plugin.xml LM jdtcore.jar 7 g plugin.xml 1} jface.jar
! 3 }
=0 Plug-in N == Plug-in "
‘\ f X o =
< phugin. xml LM resources. jar 4 plugin.xml (M ui.jar
‘ Plug-in Loader | | ﬁ}; Java Class Library |
‘ Java Virtual Machine I
‘ Operating System I

Plug-in Manifest file (plugin.xml)

- Favort igin
B plugin, sl *| 8 Favorkes.ja
# conqualityecipse Favorites views
<plugin

Plug-in Lifecycle

Plug-in registry

Lazy loading

Unfortunately, never unloaded

Equinox project (www.eclipse.org/equinox)

How to build Plug-Ins

* Plug-ins contribute functionality to the
platform by contributing to pre-defined
extension points.

» The platform has a well-defined set of
extension points - places where you can
hook into the platform and contribute
system behavior.




How to build Plug-Ins (cond’)

1. Decide how your plug-in will be integrated with
the platform.

2. ldentify the extension points that you need to
contribute in order to integrate your plug-in.
3. Implement these extensions according to the
specification for the extension points.
4. Provide a manifest file (plugin.xml) that

describes the extensions you are providing and
the packaging of your code.

Customized Editor

» An editor is a workbench part that allows a user
to edit an object (often a file). An editor is always
associated with an input object (IEditorinput).

* The interface for editors is defined in |IEditorPart,
but plug-ins can choose to extend the
EditorPart class rather than implement an
IEditorPart from scratch.

Using plug-in to enhance existing
editors

» The workbench defines extension points that allow
plug-ins to contribute behaviors to existing editors or to
provide implementations for new editors.

» The workbench extension point org.eclipse.ui.editors
is used by plug-ins to add editors to the workbench.

* Plug-ins that contribute an editor must register the
editor extension in their plugin.xml file, along with
configuration information for the editor.

» Editors can also define a contributorClass, which is a
class that adds actions to workbench menus and tool
bars when the editor is active

Exploring Eclipse Source Code

@ [workbenchPags "
@ dossEditor(JEdtorPart, bool )
@ findEdtor(Edtorinputy
@ getActiveEditor()
@ getfdiorReferences() —

@ operkditoriIFie) O MokberchSie
o savealEdiars(boolear) o getPage(
@ morkberchPartReference 7 3 o gelSelectionPiov der)
@ getld) ® getShell]
@ yelPaye() 1 B get orkbanchiyindow |
@ getPart(bovlean) @ setSelectonProvider(| SelectiorProvider]
L i ¥
@ IEdtorReference © 'wokbenchFar Q) I'WorkbenchPartSite
@ getEditor{boolean) ——— @ ceaePatControl Composie) @ getkesBinding? ervice()
@ isDirty() @ disposs() - @ gisiaContexMenu{MenuManager, |SelschorProvidsr)
@ petSie() > ® registerContextMenu(Sing. MenuM anager. | SelectionProvider]

@ *wokbenchPar » @ Edtorpat O ieditorsite
@ disposef] @ getEditorinput() @ getictionBarContributor()
getCorfiguratiorE lement]) ® getfditorSte) — 3 - @ pethctionBars()
@ geiSitel) @ gotoMarker{IMarker)
4T tis(Stival @ irit{[EditorSite, 1Edtorinput)
@* EditorPart

o getEditorInput()

& getEditorSitel)

B QoroMarker [Marker)

@ ink{IEdkorSke, [Editorinput)

(Part of) Class Hierarchy for Editor Function




Class hierarchy for Text Editor

. ) . " WorkbenchPart IEditorPart
ITextEditor is defined as a text specific o
extension of IEditorPart. T :

The implementation of ITextEditor in ‘ EditorPart ‘ ITextEditorPart

the platform is structured in layers: T =
________ I

AbstractTextEditor defines the | ; -

framework for extending the editor to AbstinctTextBditos

support source code style editing of ' T

text. This framework is defined in

org.eclipse.ui.texteditor. ‘ StatusTextEditor

The concrete implementation class ?

TextEditor defines the behavior for the
standard platform text editor. Itis

defined in the package :

org.eclipse.ui.editors.text.

AbstractDecoratedTextEditor

TextEditor

A good example

» The text editor framework provides a model-independent
editor that supports the following features:

- presentation and user modification of text

- standard text editing operations such as cut/copy/paste,
find/replace

- support for context and pulldown menus

- syntax highlighting

- content assist

- key binding contexts

» Exploring how these features can be implemented in an editor
by studying the org.eclipse.ui.examples.javaeditor example.

CVS (Concurrent Versions System )

» Help support and enhance the process of
managing source code in two major ways:

- by controlling access to the source code,
using a locking system to serialize access

- by keeping a history of the changes
made to every file.

Using CVS inside Eclipse

CVS repository parameters for CDF:

CVS Server: werewolf or seawolf
Repository Path: /ulyijun/cvsroot/c408h001
Connection Type: extssh, NOT pserver




Step 1: Creating a repository Step 1: Creating a repository
location location (cond’)

£ Add CVS Repository

1. Specify the address of CVS Add 2 new CYS Repository

hdd & new CV3 Repositery to the C¥S Repositories view

Y5 annotate RN

1. Using the Window > Open host; o
Perspective > Other command to 2. Specify the location of your =
open CVS Repository Exploring i Repositary Location. . repository; st ——; 5
Perspective. Rehesh brances... |y 3. Enter your login information; | ey ssi v coroociso =]
1 4. Select Connection Type; iy -

. . . . i . , User yaye =]
2. Right-click within the CVS Copy o Clpboard 5. Check ‘Save Password B
Repositories view and select the | & refresh view (Optional); "y
New > Repository Location Discard location 6. Click ‘Finish’ button. ;‘:';‘ue‘(‘i:‘zmj““ =
command from the context menu. _ C Use Pord: [

Properties
¥ ¥alidete Connection on Finish

Step 2: Share a project Step 2: Share a project (cond’)

® I n th e S h arl n g Share Praject with C¥S Repository

Select an existing repasitory location or create a new location. CVS

view select the oo wizard page, =3

Open in New Window

1. In the Navigator

S anpl eProj ecy

This wizard will help vou ta share vour Files with the C¥S repositary For the first bime.

p rOJ e Ct Copy Cirl4C S e | e Ct th e Wour project will sutomatically be imported inta the CVS repository, and the

Synchronize view will open to allow you to commit your resources.

Sal I I I e I r O e Ct . " Create a new repository location
' e location that was | « &
Refactor ALH45hi F14T » PR R e (15 T e [ S

. Uiexts sh:yuye@werewolfuw/yijun/cvsroot/c408h001
2. From the s preVIOusly

project's context - previou
menu choose _

Eun

Team > Share ~y

Compare ¥ith

Proj ect Yowters G Lawdd Hatis
.

Feepartios Alt+Enter |

13
]
=
g
-
4
a
&

Mext = Cancel




Step 2: Share a project (cond’)

» Specify the module
name to create on
the server. Simply
use the default
value and use the
name of the project
you are sharing.
Click Next.

£ Share Project @

Enter Module Name

Select the name of the madule in the CYS repositary. CVS

==

™ Use specified module name!

™ Use an exisiting module (this will allow you to browse the modules in the repository)

Step 2: Share a project (cond’)

» This page will allow FEEEEEEES
you to see the files
that are going to be
shared with your
team. The arrows
with the plus sign
show that the files
are new outgoing
additions.

¢ Click ‘Finish’ button

Changes
=15 SampleProject
= IF% foldert

% praject

[ Text Compare

[Eer Fle1 bt
L @il bt (A -

share Project Resources

[Fiiil

ASCIT -k,

Review and commit the project resources

E|E 8] )

ASCIL -Hhw)
A5CTT k)

]

| Frsn | Cancel

Check out a project from CVS

| 3]cws Repositories £

- ‘A HEAD
#-{= MyProject

Yo" ( ) .
o r L - - w3

L :ﬂ\
|

=l :_] :extssh:yu)'e(i‘\\'ere\x'olffu/)'ijlin/cvsrcn'»l/uc4[I8h01|1

New »

LR o arnpleProject
. Wz SomeOtherProje
& ‘ﬁk Branches
= % Yersions

Check Out

Check Out As...

Tag as Yersion. ..
Tag with Existing. ..

4N Add to Branch List...
‘p\ Configure Branches and Yersions, .,

7 Refresh View

Compare With. ..

Step 3: Synchronize with the
repository

Right-click on the resource (or
the project containing the
resource) and select the
Team > Synchronize with
Repository command.

Synchronize with Repository. ..
Coarnrmik. .,

Update

Create Patch...

apply Patch, ..

Tag as Version...
Branch...
Merge...

Change ASCII/Binary Property. ..

Show Editors
Restare from Repository...
Share Project

Disconnect. ..




Step 4: update/commit the changes

The Incoming Mode |£ Synchronize 53 || Rl Se|dB v =0
causes the view to Synchranizs (CVS Workspace)
only show incoming S-1&d com.qualityeclpse.Favorites
(SRt I =" -/ comiqualityeclipse/Favorites R :
Changes' [#1-(z39 prefersnces k
|38 FavoritesPlugin java 9 Synchronize
The Outgoing Mode = -i] ?rc,l'com,l'quaIitvecIipse,l'Favor\tes Expand Al
causes the view to B4 type _
lv sh tqoi [J1@ FavoriteltemFactory.java
only show outgoing @. FavoriteltemType. java Carntrit
Changes @l FavoriteResource. java
[=-y  srefcomfqualityeclipse/favorites Oyerride and Lpdate

The Incoming/ |J#@ ImageCache.java Overtide and Commit. ..

. . [ srefcomiqualityeclipseffavorikes  Mark as Merged
Outgoing MOd_e will |J7# Favoritesview.java ] 3
show changes in both §9 buid i ARy IOTE:
sides. '3:‘ plugin. xml ; Create Patch...

E)a preferences.ini ‘k\ Branch. .,
&8 50w Annotatio
i Showin Resource Histor

Eclipse JDK Tips - Content Assist Eclipse JDK Tips - Parameter Hints

« Content assist provides you with a list of
suggested completions for partially
entered strings.

Ctrl+Space or Edit > Content Assist

public class Main {

« With the cursor in a method argument, you
can see a list of parameter hints.

o Ctrl+Shift+Space or Edit > Parameter
Hints.

public static woid main(String[] args) {

System.out.printl if (mwoveCursor) | int selectionDffset, int selectionLangth |
¥ @ printn) vaid - PrintStream 4

H @ printin{boolean ») vaid - PrintStrear setdelecte dRangE E%t art r 0 :I E

@ printin{char x) void - PrintStream revealRangE |: start R length:l H
@ printin{char[] =) woid - PrintStream

@ printin{double ) woid - PrintStream }
@ printin{float x) void - PrinkStream

@ printinfint ) void - PrintStream

@ printin{lang =) void - PrintStrean

@ printin{Object x) void - PrintStream v




Eclipse JDK Tips - Quick Fix

e Start with the method invocation and use
Quick Fix to create the method.

e Ctrl+1

return getRegiupﬁl[start, length) ;

E Create method 'getRegionfint, ink)’

Eclipse JDK Tips — Code Navigation

» There are two ways that you can open an
element from its reference in the Java
editor.

1.Select the reference in the code and press
F3 (Navigate > Open Declaration)

2.Hold Ctrl and move the mouse pointer
over the reference.

Meszageliglog.openError (£5hell, title, messade) !
return;

Eclipse JDK Tips — In-place
outlines

* Press Ctrl+F3 in the Java editor to pop up
an in-place outline of the element at the
current cursor position.

| -

public static String getResource
ResourceBundle bundle = Favc
tey |

3

# Edit
5 SNmTRE ceBundle ()
=& Faveritelditer

plugin = FavoriteBditor
urn (bundle '= null)

rezourcel Bundle : Resourcel Bund
} vatch (HissingResourceExce &S Pavoritelditor O
urn key; @ . start (BundleContext)
} @ & stop (BundleContext]
¥ [ getDefanlt ()

@ ° gethesourceString Gtring)
@ gethesourceBundle()
@ testQuickfix()
B quick(int)
public ResourceBundle getResourc
wn resourceBundle;
¥ < »

public int cestQuickfix(){

Eclipse JDK Tips — In-place
hierarchy

» Place the cursor inside the method call
and press Ctrl+T.The view shows all types
that implement the method with a full icon.

control.EEHdEEEly (true) ;

Types implementing or defining ‘Control.setRedraw(boolean)’
|

=@ Ohject - java.lang
] '3:::3"'\ 'Widget - org.eclipse, swk, widgets
=-K3* Cantral - org.eclipse. swt.widgets

= '3:::1"'\ Scrollable - org.eclipse, sw,widgets
=8  Composite - org. ecipse. swk widgets
© Table- org. eclipse, swk,widgets
® Tree- org.eclipse,swk,widgets

® Text- org.eclipse, swk, widgets

Press 'Ctl+T" to see the Supettype hierarchy




Eclipse JDK Tips - Refactoring Eclipse JDK Tips

» Select the element to be manipulated in
the Java editor or in a Java view and press _ _ _
Alt+Shift+T for the quick refactor menu. Eclipse Help > Tips and Tricks...

» More Tips and Tricks can be found in

=eEdd. lengthi) > 0) {
i i Alk+Shift+R
¥ Move, .. Alt+Shift+y
Change Method Signature. .. Alk-+Shife+C
Pull Up,..

Extract Interface. ..
Generalize Type...
Use Supertype Where Possible, ..

Inline. .. Alk+3hift+1
Extract Methad. .. Alk-+Shife+1
Extract Local Yariable. .. Alb+Shift+L

Extract Constant. ..
Introduce Parameter, ..
Conwert Local Yariable to Field...  aAlk+Shift+F

Checkout the right version of the
Editor part

CVS repository:

Reference

» Eclipse 3.0 Help

» << Building Commercial Quality Eclipse
Plug-ins >>

» << Eclipse In Action >>

Versions
org.eclipse.ui.editors
org.eclipse.ui.editors R3_0
Checkout




